Client Login     (Register)


 

 

TandyUK Servers

 

Comprehensive business and personal hosting packages for all your needs

 
 

Knowledgebase

PHP Version Selector

Our shared and reseller hosting use CloudLinux LVE, which means we can offer you the ability to customise the PHP version used by your site.
In some specific cases you may need to change PHP version, or enable extensions such as PDO or ffmpeg on your web hosting account at TandyUK.
We have implemented a server setup model that allows each customer to choose which version of PHP to use, and customise the loaded extensions and configuration options.

Finding your default PHP version

Before changing your PHP version, you may find it useful to know which version you are running by default.
You can do this one of two ways – by using the phpinfo function or alternatively following the following simple steps:

1. Log in to your cPanel account.
Cpanel Web interface

2. In the left hand column, you will find an entry 'PHP Version'. You may need to click 'expand stats' at the bottom first.

PHP Version

This php version is the system default, and will be in use unless you have changed it.

Changing your PHP version

Some of our customers wish to change their PHP version, or load specialist modules.
Please do not try to change PHP settings via .htaccess – instead follow these steps:

1. Log in to your cPanel account.

2. If you scroll down, you’ll see a box titled ‘Software/Services’.

Select PHP Version

3. The system default PHP does not allow you to change anything.
From the dropdown menu you can select the PHP version that you want, and click 'Set as current'.

Default PHP version

4. You can now customise the php extensions to be loaded.
The available extensions will vary between PHP versions.
Try not to enable extensions unless you understand why you need them, and how to configure them.
Generally speaking, more extensions means it will take longer for PHP to load each time your website gets a hit.
The default selections are fine for the majority of sites, however large dynamic sites may benefit greatly from opcache.
Once you have made changes, click 'Save' at the bottom.

Available PHP Extensions

5. Some PHP options can also be changed, for example memory limt, execution time and maximum file upload size.
Click the 'Show PHP Settings' button top right to see them.

Configurable PHP options

6. To change an option, click on the value, and once you are done making changes click 'Save'.

Choose PHP option

Recommendations

We highly recommend to use the current PHP branch (5.4.x at the time of writing), and adapt your scripts accordingly.
PHP 5.3.x is now EOL (End Of Life), so we would no longer recommend using that version.

If you’re using a ready-made PHP-based software (CMS, forum, shopping cart, etc) – be sure it’s up to date.
In case the latest version of your software doesn’t support PHP 5.4.x – contact your software vendor for a new version or PHP 5.4 compatibility patch.

 



Was this answer helpful?

Add to Favourites
Print this Article


Powered by WHMCompleteSolution

Terms and Conditions | Complaints